Tcl Library Source Code

Ticket Change Details
Login
Overview

Artifact ID: a5567f3349cd9a38475c4888c0a64960f555b40170a0bcf75ca6acfb5926d0be
Ticket: 30526e902772c23159e2fd166323bd2cc101b939
math::exact: ifneeded/provide version mismatch
User & Date: ssoberni 2018-08-06 12:03:21
Changes

  1. Change assignee to "nobody"
  2. Change closer to "nobody"
  3. Change cmimetype to "text/plain"
  4. Change comment to:

    There is a mismatch between the version number provided (1.0.1) and the one required (1.0) which yields a:

    attempt to provide package math::exact 1.0 failed: package math::exact 1.0.1 provided instead

    Fix is to patch the ifneeded script in modules/math/pkgIndex.tcl to show

    package ifneeded math::exact 1.0.1 [list source [file join $dir exact.tcl]]

    instead of

    package ifneeded math::exact 1.0 [list source [file join $dir exact.tcl]]

  5. Change foundin to "trunk"
  6. Change is_private to "0"
  7. Change login to "ssoberni"
  8. Change priority to "5 Medium"
  9. Change private_contact to "d4d1d8192a46acf2c7d58cddc1040ecdbc9c9d77"
  10. Change resolution to "None"
  11. Change severity to "Severe"
  12. Change status to "Open"
  13. Change submitter to "ssoberni"
  14. Change subsystem to "math"
  15. Change title to "math::exact: ifneeded/provide version mismatch"
  16. Change type to "Bug"